Find answers, ask questions, and connect with our
welcoming community.

Home Page Forums General Discussions Updating Commix ?

  • Updating Commix ?

     Anthony updated 2 weeks, 5 days ago 2 Members · 6 Posts
  • Anthony

    Member
    May 15, 2021 at 2:42 pm

    [warning] You haven’t updated commix for more than 32 days!

    Please enter full target URL (-u) >

    ———————————————————————-

    I have two different problems with Commix:

    – I use the one that comes preinstalled with Parrot OS it works fine but then i get this message of i have not updated it in 32 days ???… I tried to update but for some reason does not update successfully.

    – I also used the Master Commix version from one of your lessons, and it works well but i am confused.

    ———————————————————————————

    Which one should i use for training and when i feel comfortable for live hacking when i want to search for OS command injection vulnerabilities ?… What are the exact commands i can use to update and use Commix successfully without many problems, thank you.

  • Christophe

    Administrator
    May 17, 2021 at 4:14 pm

    Hey Anthony,

    1- To update commix and other tools + Parrot OS, check out the documentation here. They offer 3 methods under “How do I upgrade my system.” Let us know if that doesn’t work!

    2- In terms of which version you should use, that is up to you. The latest versions will typically have more features and hopefully be more stable. If the versions are close to one another, though, unless there was a big change, they should be similar and return similar results.

    • Anthony

      Member
      May 18, 2021 at 1:20 pm

      Hmm, well i tried all three methods and the first two say i am updated but whenever i open Commix itself it tells me.

      [warning] You haven’t updated commix for more than 35 days!

      [critical] Missing a mandatory option (-u, -l, -m, -r, -x, –wizard, –list-tampers, –purge or –dependencies). Use -h for help.

      • Christophe

        Administrator
        June 2, 2021 at 6:20 pm

        hmm that’s odd. A workaround in the meantime would be to download the latest straight from github, and then you can just pull updates from that repository over time

        • Anthony

          Member
          June 3, 2021 at 1:10 pm

          I decided to go with a different OS so i installed and updated Kali-Linux, and it works just fine my Parrot OS i was originally using is still functional. But for some reason no matter how are hard i diagnose and troubleshoot it’s still a problem. So i am good for now and ready to go thank you, Chris.

  • Anthony

    Member
    May 18, 2021 at 12:18 pm

    Thank you i will check it out and see if it works in my case.

Viewing 1 - 3 of 3 replies

Log in to reply.

Original Post
0 of 0 posts June 2018
Now