Find answers, ask questions, and connect with our
welcoming community.

Home Page Forums Course Discussions Cross-Site Scripting (XSS): The 2021 Guide Trying to get Beef working – having issues

  • Trying to get Beef working – having issues

    Posted by Jen on December 31, 2021 at 9:11 pm

    28/28) Installing sqlite-dev (3.28.0-r3)
    Executing busybox-1.30.1-r2.trigger
    Executing ca-certificates-20190108-r0.trigger
    OK: 226 MiB in 62 packages
    You must use Bundler 2 or greater with this lockfile.
    The command ‘/bin/sh -c apk add –no-cache git curl libcurl curl-dev ruby-dev libffi-dev make g++ gcc musl-dev zlib-dev sqlite-dev && bundle install –system –clean –no-cache –gemfile=/beef/Gemfile $BUNDLER_ARGS && rm -rf /usr/local/bundle/cache’ returned a non-zero code: 20

    seemed to have gone down a rabbit hole of having to update way to many things

    Christophe replied 4 months, 3 weeks ago 2 Members · 2 Replies
  • 2 Replies
  • Jen

    Member
    December 31, 2021 at 9:39 pm

    seems to have been resolved by deleting the Gemfile.lock file

  • Christophe

    Administrator
    January 5, 2022 at 4:27 pm

    I also had some similar issues recently, and I believe it has to do with version mismatches. Thanks for sharing the solution!